DragStuff.com

 Subscribe in a reader


FORUM | DIRECTORY | CLASSIFIEDS | TECH

It is currently Sat Nov 01, 2014 7:58 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Tue Oct 12, 2010 3:11 pm 
Offline

Joined: Sat Mar 21, 2009 9:21 pm
Posts: 13
Location: Reading PA
fourtenposi wrote:Another vote for the driveshaft, But I think it may be too short. Had a buddy of mine, Got him some good shocks on the car that made it dead hook, 3 passes later, broke the case. So thinking it may have been just one of those deals, replaced the case again. 3 passes later, broke the case. So really started to look at things, noticed that there was probably over an 1/8 inch of play in the transmission yoke up and down. Replaced the case again, measured for new driveshaft , and new driveshaft came back 3/4 of an inch longer. Hasn't had a problem with it since.

I would get under the car with everything at rest and see if you can feel any significant play in it.

My car went all year i have over 240 passes on it before it broke this time. Before that i had rubber motor mounts and the ears cut off trans. Last year it broke the bell on its first outing so i had a balanced driveshaft made sold mounts and didnt cut the ears off the case. I am going to try the driveshaft angle gauge before i run it next year. thanks for the help


Top
 Profile  
 
PostPosted: Tue Oct 12, 2010 3:31 pm 
Offline

Joined: Sat Mar 21, 2009 9:21 pm
Posts: 13
Location: Reading PA
John_Heard wrote:My memory isn't great on this, but it seems to me his first problem was a broken tailhousing, maybe two of them, then he broke a bell housing. I believe he did the driveshaft change, added pinion snubber and put a different transmission in it all at the same time and problem went away. Hard to tell which one was actually the problem.

I believe it was a turbo 350

I am putting the trans in tomorrow going to drive it on the street to see if i have any vibration then back to the driveshaft shop to see what they have to say. rip shit or bust wish me luck


Top
 Profile  
 
PostPosted: Fri Oct 15, 2010 9:16 am 
Offline
User avatar

Joined: Tue Dec 11, 2007 2:04 pm
Posts: 27
Location: chillicothe mo.
same here was building a camaro had a 468 in it doing it a friends shop he dropped motor when i wasnt there bent flexplate replaced it with one he had but motor had no dowell he just bolted it on wrong i went through three bell housings before i found the problem turned the flexplate and added a dowell ran smooth no more breaking bell housings


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group