Weird Battery Issue

Everything involved with getting to the track and working in the pits

Moderator: John_Heard

Post Reply
Message
Author
User avatar
BracketNova
Posts: 618
Joined: Sat Apr 25, 2009 6:46 pm
Contact:

Weird Battery Issue

#1 Post by BracketNova » Wed Sep 07, 2011 10:21 pm

I have three batteries in the front of my trailer I just picked up. My issue is two of the batteries are down to 5 volts and one is at 12.7. Each battery is grounded seperately. Battery A (5.7 volts - older battery) is connected to Battery B (12.7 volts - new battery), Battery B also connects to Battery C (5.7 volts - new battery). The positive wire between A and B has 0 ohms resistance and the positive between B and C is 20 ohms.

My assumption is Battery A battery is pulling down Battery C...but I can't figure out why the one is still at 12.7 volts. There is an isolator in the system but it just seperates the recharge wire to the truck from the house 12 volt stuff.
"I always compare drag racing to lighting $100 bills on fire, only it's more expensive." - Craig W.

Check out my website...
http://www.findmoneyraces.com


'71 Nova E85
6.69 @ 100.2 MPH 9/6/14
1.4257 60'
1700' DA

13:1 439 BBC
3330 lbs

User avatar
John_Heard
Site Admin
Posts: 5684
Joined: Thu May 12, 2005 11:20 am
Location: Resume Speed, Kansas
Contact:

Re: Weird Battery Issue

#2 Post by John_Heard » Fri Sep 09, 2011 8:44 am

Sounds like you need to disconnect all of them, charge & load test to see which ones are bad.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests