Stocker help...

General Engine Discussion

Moderator: John_Heard

Post Reply
User avatar
Posts: 643
Joined: Thu Sep 21, 2006 1:00 am
Location: Pelahatchie,MS

Stocker help...

#1 Post by mytmouz » Sun Mar 03, 2013 12:51 pm

Recent tow pig acquisition is giving me fits. This is a 1997 Chevy C2500 2wd with a 5.7 vortec. Truck had been sitting for a while when I got it. I had to put a fuel pump in it to get it running. Runs fine, EXCEPT at idle.

Throws a P300 random misfire code, and a P304 code for a specific cylinder misfire, but it will rotate cylinders, and different sides of the engine. It had these codes when first fired up, and all efforts so far have made no change. Replaced the dist. cap. rotor button, plugs and wires as normal maint, after it was first fired.

The gas was jellied in tank when I got it, we cleaned it out, and replaced fuel filter when replacing the pump. Replaced spyder injection with an unknown used set, did not help.

Bought another complete intake off a running engine. Swapped EGR, new PVC, coolant sensor, replaced turtle from intake I bought, transferring all sensors as well. Same result. Left original lower on as it seems fine.

Carried truck to local "Guru" as I am only out about 40 bucks in parts so far, (intake was $25, and the PVC was new, plugs and such were routing maint). Did not want to throw parts at it. They swapped the distibutor and the MAF from a truck in the shop, same result, mine ran fine on the other truck.

Here is where the fun part comes in. While troubleshooting further on my own I found the truck PULLS air into the engine via any of the vacuum related items. The oil cap will 'whistle' when loosening it while truck is running, will not die when it is off. I pulled every vacuum related item at different times, with no change.

Unplugging the MAF will not change idle, but it will throw a code for it. Unplugged all the vaccum items and it will still run.

There is a tube from the platic air intake elbow to the passenger valve cover, if you unplug the tube, and hold your thumb over the tube going into the valve cover, it will pull MAJOR vacuum.

Compression is fine on all cylinders, no water in oil, or vise versa, pressure test of coolant is fine as well.

One last thing, while the engine has a rough idle with the oil filler cap off, it will NOT throw either of the misfire codes. Within 30 seconds of reinstalling it, it will come back.

Trucks are for haulin...


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests