Father's Day

Bench Racing - Misc. Discussions

Moderator: John_Heard

Post Reply
Message
Author
User avatar
Bruce69Camaro
Posts: 1781
Joined: Thu Jul 23, 2009 11:07 am
Location: PA

Father's Day

#1 Post by Bruce69Camaro » Mon Jun 17, 2013 6:13 am

First I wanted to wish all you fathers, young and old a belated Father's Day.

Second, I got to take the Camaro out for it's first showing. Our church had a Father's Day car/ bike show and then our pastor blessed each vehicle for safety throughout the year.

I didn't know I needed this blessing so soon! before I get into that, not wanting to toot my own horn, but the car turned out to be a real crowd pleaser and there were some very nice cars there.

But anyhow, everyone wanted to see me take our pastor for a ride, so I did and I wanted to drive the car on a nice straight road, because I never actually drove this car for a good distance, and there just happen to be a 1/8" stretch of road, next to the church so off we went. It was in low and I punched it and it really surprised me. The motor had some good power behind it and I hit second and then it had a bad vibration up front. I got slowed down and punched it again and this time I had some fun, the car started swinging left to right and it really woke up but again I started hearing some noises I didn't like and even John looked at me and said, what was that.

So I took it slow and the one noise was the slicks chirping when I turned to sharply but the vibration and the other rubbing noise I couldn't figure out. So my coworker Nelson showed up with my ride home (a roll back) and we loaded it up and he was looking under the car when he noticed the driveshaft was rubbing the rear saftey loop on my crossmember. So back at home, we got it into the garage, which was a pain and I jacked it up and sure enough, nothing was broke but it was hitting and rubbed the painted off the driveshaft.

Then it hit me, I lowered the ride height in the rear down an 1" and that caused this problem. So after looking at the rulebook and talking to my coworker, I beleive I don't need this saftey loop and please someone correct me if I'm wrong, I only need the safety loop behind the tranny and if so, I'm just going to cut this loop off and be done with it. Anyone see a problem with this?

But all in all, man I had fun and the car has a bit more then I thought it did. K-Star did a good job on the motor, and my coworker sure did a nice job on the paint and on the tranny....
Those who think they know it all have no way of finding out they don't......... :scratch:

User avatar
Hitchcock
Posts: 1534
Joined: Fri Sep 12, 2008 6:57 pm
Location: Wichita

Re: Father's Day

#2 Post by Hitchcock » Mon Jun 17, 2013 6:38 am

You can remove it and be fine. Glad you're getting it out.
73 Vette, moly back half
Pump gas 496
Two Pro Systems 950's
Chance 6000 converter

User avatar
Bruce69Camaro
Posts: 1781
Joined: Thu Jul 23, 2009 11:07 am
Location: PA

Re: Father's Day

#3 Post by Bruce69Camaro » Mon Jun 17, 2013 6:53 am

yeah...... :smt038 :smt038 :smt038 I thought so.

Thanks Hitch. How's the Vette?
Those who think they know it all have no way of finding out they don't......... :scratch:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest