0-60, shifting, throttle engagement help!

Bench Racing - Misc. Discussions

Moderator: John_Heard

Post Reply
Message
Author
JMASTERJ
Posts: 1
Joined: Sun Oct 18, 2015 8:07 pm

0-60, shifting, throttle engagement help!

#1 Post by JMASTERJ » Sun Oct 18, 2015 10:09 pm

Hey guys, hope you're all well...

So last week I was at a stop light, and there was a luxury Lexus next to me, driven by an older gentleman and his wife. Usually I don't drag because most cars don't come close to being competition (you'll find this statement ironic later) so it is few and far in between, especially in the area I live in. Anyways, I had to start hard to cut over to the other lane to make a turn about 1/4 mile down, so I started a "conservative hard" start... then I noticed the Lexus busting out himself, so I said, might as well go go go... well I had some sloppy throttle control, and bad shifting, and in just over 1/8 he was a couple car lengths ahead and I was feeling well, like a shmuck really.

Now I have no doubt that car had more HP than me and he probably just put the petal to the metal in his automatic just for childhood thrills, good from him. However, this made me think, what exactly AM I doing with this, am I even using my ZHP to its full potential? So late that night I went to an desolate strip of road and did a little 0-60 test. The result was absolutely appalling, if not embarrassing and an utter

Just over 9 sec. Yes that is 9 and in nine, before 10. Now the specs say ~5.6, but I think definitely under 6 sec. I did it 3 times, every time, over 9s. Anyways this got me thinking, GET HELP.

This is what I know:

• I pop the clutch around 4k RPM so I get a slight free spin for like a couple milliseconds, I think thats proper?
• I did NOT floor the gas but came very close the first couple times... then the third time I did, no change in time. Each pressure was fast but gradual, never just slamming the gas to the metal, I think that's proper?
• I tried twice getting into 3rd and once staying in 2nd... I discovered you HAVE to get into 3rd... lose way too much power at the end of 2nd by about the 40-50mph mark
• Steering was pretty much dead straight, no wiggly lines there
• Shifting was not the best and I did not double clutch or anything else, but 3+ seconds worth of 2 shifting mistakes? Each shift was around 5700-5800 RPM I think

I am no drag expert, so I MUST be missing something vital here. The funny thing is, even the 9 sec doesn't really feel SLOW, but then again maybe I am just used to it and don't know any better.

Help?

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests