1970 Cuda 4 speed 60 ft problem

Suspension Tuning, Troubleshooting, Design and Discussion

Moderators: David Lemmond, Dave Morgan

Message
Author
raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#151 Post by raffaplymouth » Wed Sep 05, 2012 2:04 pm

Bruce69Camaro wrote:I'm suppose to tell you to sign up over at this site: http://www.cuda-challenger.com/cc/index.php

I think they got word that your making us a spaghetti dinner and they want some.......actually I know one of the administrators and I was talking to him about you and your car.
ok, spaghetti for everyone!! i will look this website !!
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#152 Post by raffaplymouth » Fri Sep 07, 2012 3:24 pm

Guys , i can ask a question of fuel in this thread? , i see a strange thing .. my fuel pressure normally is 7-8 psi. i have 2 holley black electric fuel pump , one for carb and one for nitrous ....at engine hot , at finish line ....carburetor fuel pressure drop to 4-5 psi and also nitrous fuel line ... this is normal ?? if wait 10 minute pressure return to 7 psi ...
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

User avatar
John_Heard
Site Admin
Posts: 5699
Joined: Thu May 12, 2005 11:20 am
Location: Resume Speed, Kansas
Contact:

Re: 1970 Cuda 4 speed 60 ft problem

#153 Post by John_Heard » Fri Sep 07, 2012 3:47 pm

Do you have a corresponding voltage drop as well?

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#154 Post by raffaplymouth » Tue Sep 11, 2012 3:54 pm

i found problem on a Relais ... voltage was low , now is ok at 13.70 volts !! another question guys , i can use sometimes this car on the highway ?? or i can destroy the engine ?? valve spring ?? i have .720 lift ....
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#155 Post by raffaplymouth » Sat Nov 03, 2012 3:35 pm

hey guys , how are you ?? i would be change the rear tires with 30" , now i have 28, with the same width 10" .. for you the 60 ft will be better ??
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

User avatar
Hitchcock
Posts: 1534
Joined: Fri Sep 12, 2008 6:57 pm
Location: Wichita

Re: 1970 Cuda 4 speed 60 ft problem

#156 Post by Hitchcock » Sun Nov 04, 2012 8:10 am

raffaplymouth wrote:hey guys , how are you ?? i would be change the rear tires with 30" , now i have 28, with the same width 10" .. for you the 60 ft will be better ??

Its hard to tell, it may help with tire spin off the line and calm the launch down. Only thing to do is try it and see if the car like it. Been at the track much lately?
73 Vette, moly back half
Pump gas 496
Two Pro Systems 950's
Chance 6000 converter

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#157 Post by raffaplymouth » Wed Dec 26, 2012 5:00 am

Some pictures ...

Image

Uploaded with ImageShack.us

Image

Uploaded with ImageShack.us
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

User avatar
wikd69
Posts: 2068
Joined: Sat Feb 23, 2008 12:42 pm
Location: Rocklin, CA
Contact:

Re: 1970 Cuda 4 speed 60 ft problem

#158 Post by wikd69 » Fri Dec 28, 2012 4:17 am

raffaplymouth wrote:Some pictures ...

Image

Uploaded with ImageShack.us

Image

Uploaded with ImageShack.us
Beautiful shots, thanks for sharing those Raff :)
1969 ProStreet Camaro RS Best 9.75@139 1.46 60'
Blown 427 BBC, TH400 w/Brake, Back-Half Ladderbar
Narrowed 12-Bolt, 4.10 Gears, Spool, Moser 33 Spline

http://www.marsh-racing.com/harrys_camaro-1.htm

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#159 Post by raffaplymouth » Sun Dec 30, 2012 5:56 am

Guys , im looking for fiberglass bumpers on ebay , and new rear tires , im undecide if increase the tire diameter from 28 to 29 ... and if change brand from MT to good year , i accept any advice ---
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

User avatar
sc68z28
Posts: 189
Joined: Sun Jan 15, 2006 8:28 pm
Location: Riverside California

Re: 1970 Cuda 4 speed 60 ft problem

#160 Post by sc68z28 » Sun Dec 30, 2012 6:32 pm

I ran the 28x 10.5W MT on a 10" wheel, then switched to 29x 12 GY on a 12" wide wheel.

My car (5 speed) the 29" GY hooked much better.

On a good track they (the GY) will dead hook, that can be a problem for a clutch car.
Some wheel speed (spin) is actually needed or things will break and/or you will be driving thru the clutch.

---Bill.
68 Camaro, 380ci, Procharger, G-force 5 speed, EFI, 7" 2 disc clutch, best ET 8.69 @159
Best 60' vid http://www.youtube.com/watch?v=1OLzx5jBo4w

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#161 Post by raffaplymouth » Sun Jan 06, 2013 3:41 am

sc68z28 wrote:I ran the 28x 10.5W MT on a 10" wheel, then switched to 29x 12 GY on a 12" wide wheel.

My car (5 speed) the 29" GY hooked much better.

On a good track they (the GY) will dead hook, that can be a problem for a clutch car.
Some wheel speed (spin) is actually needed or things will break and/or you will be driving thru the clutch.

---Bill.
Bill !! and for the gear ratio ? you will change ?? my cuda at finishline was at 6700 .... my rpm limit is 7200
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

User avatar
sc68z28
Posts: 189
Joined: Sun Jan 15, 2006 8:28 pm
Location: Riverside California

Re: 1970 Cuda 4 speed 60 ft problem

#162 Post by sc68z28 » Sun Jan 06, 2013 9:22 pm

4.56:1 should work well.

---Bill.
68 Camaro, 380ci, Procharger, G-force 5 speed, EFI, 7" 2 disc clutch, best ET 8.69 @159
Best 60' vid http://www.youtube.com/watch?v=1OLzx5jBo4w

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#163 Post by raffaplymouth » Tue Jan 08, 2013 6:05 pm

sc68z28 wrote:4.56:1 should work well.

---Bill.
Now i have 4.10 ...
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

User avatar
sc68z28
Posts: 189
Joined: Sun Jan 15, 2006 8:28 pm
Location: Riverside California

Re: 1970 Cuda 4 speed 60 ft problem

#164 Post by sc68z28 » Wed Jan 09, 2013 10:52 pm

Yes, 4.10 is good...
4.56 just a little better, but probably NOT a big deal.

---Bill.
68 Camaro, 380ci, Procharger, G-force 5 speed, EFI, 7" 2 disc clutch, best ET 8.69 @159
Best 60' vid http://www.youtube.com/watch?v=1OLzx5jBo4w

raffaplymouth
Posts: 162
Joined: Tue Jul 24, 2012 2:07 pm

Re: 1970 Cuda 4 speed 60 ft problem

#165 Post by raffaplymouth » Fri Jan 18, 2013 11:39 pm

sc68z28 wrote:Yes, 4.10 is good...
4.56 just a little better, but probably NOT a big deal.

---Bill.
Guys ... First race is close to 2 month ...this year my goal is 9,90 .. I have a idea to change trasmission from manual to automatic 3 speed torqueflite .. What do u think ? Jerico transmission is too expensive ! ... I want my 60 ft lowered ... Now is 1,65 sec ...
1970 Super Cuda 496 Indyheads
ET 9.32@148 1.42 60ft (250 shot ) :shock:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests